2016年3月12日土曜日

FreeBSD CUPS, SAMBA のアップデート

FreeBSD の ports へ CUPS や SAMBA のアップデートが到着しました。
cups-base-2.0.3_5           <  needs updating (port has 2.1.3) (=> 'print/cups')
cups-client-2.0.3_2         <  needs updating (port has 2.1.3) (=> 'print/cups')
cups-image-2.0.3_2          <  needs updating (port has 2.1.3) (=> 'print/cups')
flex-2.6.0                  <  needs updating (port has 2.6.1)
ghostscript9-base-9.06_11   <  needs updating (port has 9.06_12)
gtk2-2.24.29                <  needs updating (port has 2.24.29_1)
samba36-3.6.25_2            <  needs updating (port has 3.6.25_3)

CUPS はメジャー・アップグレード(2.0.3 から 2.1.3 へ)となっており、portmaster でそのままアップグレードができませんでした。
# portmaster -ad
CUPS のビルド・オプション

CUPS のインストール先に古い CUPS があるということで portmaster は停止しました。

そこで CUPS をアンインストールしました。関連して依存関係にあった SAMBA もアンインストールされました。
# pkg delete cups-base-2.0.3_5 cups-client-2.0.3_2 cups-image-2.0.3_2

Updating database digests format: 100%
Checking integrity... done (0 conflicting)
Deinstallation has been requested for the following 7 packages (of 0 packages in the universe):

Installed packages to be REMOVED:
    cups-base-2.0.3_5
    cups-client-2.0.3_2
    cups-image-2.0.3_2
    gtk2-2.24.29
    samba36-3.6.25_2
    ghostscript9-base-9.06_11
    gtk-engines2-2.20.2_2

The operation will free 205 MiB.

Proceed with deinstalling packages? [y/N]: y

そして再度 portmaster で新規インストールし直しました。
# portmaster -d print/cups x11-toolkits/gtk20 textproc/flex print/ghostscript9-base net/samba36

0 件のコメント:

コメントを投稿